Bluestream Health Minimum Requirements and Best Practices

Bluestream Health has recently updated our minimum requirements and best practices to utilize when using our software. This information is useful when onboarding new clients, or connecting to a session on the Bluestream Platform, and ensures the best session possible. 

Operating System  

  • Windows: Windows 10 and above
  • Mac: OS X 10.6 and above  
  • iOS Best Practices: Apple suggests their users keep their iPhone and iPad up-to-date with the most current version of iOS. iOS is currently on version 16.5. We strongly encourage all iOS users to upgrade their devices to iOS 16.5. While our software is still compatible with lower versions of iOS, we have seen improved audio and video quality (i.e. better image resolution, less static sounds, less audio echoing, less disconnects) with the latest version of iOS.
    • iOS 16.5 Compatible iPhones: All iPhone 13 Models, all iPhone 12 Models, all iPhone 11 Models, all iPhone X Models, and all iPhone 8 models.
    • iOS 16.5 Compatible iPads: iPad mini (6th generation), iPad (10th generation), iPad Air (4th generation), iPad Air (5th generation), iPad Pro 11-inch (1st generation), iPad Pro 11-inch (2nd generation), iPad Pro 11-inch (3rd generation), iPad Pro 11-inch (4th generation), iPad Pro 12.9-inch (3rd generation), iPad Pro 12.9-inch (4th generation), iPad Pro 12.9-inch (5th generation), iPad Pro 12.9-inch (6th generation), Pad mini (5th generation), iPad (5th generation), iPad (6th generation), iPad (7th generation), iPad (8th generation), iPad (9th generation), iPad Air (3rd generation), iPad Pro 9.7-inch, iPad Pro 10.5-inch, iPad Pro 12.9-inch (1st generation), and iPad Pro 12.9-inch (2nd generation). You can also view these details on Apple’s page, here
  • Android 5.0 or newer 

Browser  

For the best in-call experience, Bluestream Health suggests updating your browser to the newest version. 

  • Google Chrome 67.0 and above  
    • For instructions on how to update Chrome, click here
  • Mozilla Firefox 52.0 and above  
    • For instructions on how to update Firefox, click here
  • Safari 14 and above  
    • For Instructions on how to update Apple/Safari, click here
  • Edge 92 and above, effective October 1st, 2021  (Windows and Mac OS only)
    • For Instructions on how to update Edge, click here
Processor  

  • Intel i3 or better  
  • AMD A8 or better  

Memory  

  • RAM: Minimum 2GB  
  • Memory: No installation or local storage required  

iOS Devices  

  • iOS 16 or newer  

Android Tablets and Phones  

  • Android 5.0 or newer with sufficient processing power to transcode video  

Bandwidth Requirement  

  • Minimum 500Kbps

Note: Devices and web browsers not listed above may experience interruptions in service.

 

To confirm you or a client are ready for a Telehealth or Interpreting Session on the Bluestream Platform, you can run our Free Tech-Check Test, here: https://tech-check.bluestreamhealth.com/connection-test. 

 

For Firewall Ports and IP Ranges, any questions on the minimum requirements, or to schedule a troubleshooting session,  please contact ProdSupport@Bluestreamhealth.com. 

For a look at Bluestream Health's Security Overview, click here

 

Contact: Prod Support
ProdSupport@bluestreamhealth.com